New Case Creation
Incident Report for Lunar CRM
Resolved
We've located and fixed the problem. Users should restart their browsers if the problem persists.
Posted Jul 18, 2024 - 16:33 BST
Investigating
Some users are seeing errors when trying to create new cases. We're currently investigating this.
Posted Jul 18, 2024 - 16:14 BST
This incident affected: CRM.