Essential System Maintenance
Incident Report for Lunar CRM
Resolved
Maintenance has been completed.
Posted Jan 18, 2022 - 08:44 GMT
Identified
We are currently undertaking some essential system maintenance. Services may appear unresponsive for a short period of time.
Posted Jan 18, 2022 - 08:38 GMT
This incident affected: CRM, Letters / Emails / SMS, and Reports.