Degraded Performance
Incident Report for Lunar CRM
Resolved
Maintenance work has been completed and all systems are in working order.
Posted Sep 21, 2023 - 07:38 BST
Identified
We have identified the issue and we have scheduled overnight routine server maintenance to alleviate the problem.
Posted Sep 20, 2023 - 14:30 BST
Investigating
Some users are seeing degraded performance when access cases and running reports. We are currently investigating this issue.
Posted Sep 20, 2023 - 13:56 BST
This incident affected: CRM and Reports.