Essential Maintenance
Incident Report for Lunar CRM
Resolved
All systems are back up and running.
Posted Jan 12, 2024 - 07:59 GMT
Investigating
We are currently carrying out essential server maintenance. Systems will be available in a few minutes.
Posted Jan 12, 2024 - 07:58 GMT
This incident affected: CRM, Letters / Emails / SMS, and Reports.