CRM Response Times
Incident Report for Lunar CRM
Resolved
This incident has been resolved.
Posted Mar 19, 2024 - 07:51 GMT
Investigating
Some users have reported slow CRM responses around 4:15 today. We are investigating why this occurred.
Posted Mar 18, 2024 - 16:24 GMT
This incident affected: CRM, Letters / Emails / SMS, and Reports.