Degraded Performance
Incident Report for Lunar CRM
Resolved
This incident has been resolved.
Posted Jan 12, 2022 - 16:00 GMT
Identified
We have identified a potential issue and are investigating further.
Posted Jan 12, 2022 - 13:48 GMT
Investigating
Some users are reporting slightly degraded performance. We have no known issues but are investigating.
Posted Jan 12, 2022 - 12:51 GMT
This incident affected: CRM, Letters / Emails / SMS, and Reports.