CRM Connection Problems
Incident Report for Lunar CRM
Resolved
This incident has been resolved.
Posted Jun 17, 2022 - 08:31 BST
Update
We are continuing to investigate this issue.
Posted Jun 16, 2022 - 18:52 BST
Investigating
Some users are experiencing problems connecting to the CRM.

The CRM is in full working order. We're looking at other potential problems.
Posted Jun 16, 2022 - 17:58 BST
This incident affected: CRM.